What devices are supported?

Beamer supports the Apple TV (2nd, 3rd and 4th generation). Beamer 3.0 and later also support Chromecast (1st and 2nd generation).

For Apple TV, software version 5.3 or higher is required.

Was this article helpful?

Can’t find the answer you’re looking for? Contact Support