Where can I download a previous version?

Download Beamer 1.7.8 here. Requires OS X 10.6 or higher.

Please note that Beamer 1 uses a different license scheme – you'll need a name and license key. These licenses are no longer available for purchase.

Was this article helpful?

Can’t find the answer you’re looking for? Contact Support